Great way to learn is by example so fire up
Visual Studios C++ 2017 or 2019

by Deborah R. Fowler
www.deborahrfowler.com
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At home Visual Studio 2017/19 Community be sure you
check options for C++ (no longer default)

You can modify your existing install
Launch visual studios installer from start menu

OR

Tools-> Get Tools and Features > Modify
(see next slide)
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Adding C++ Functionality to Existing VS 2017 Community

Z‘J Start Page - Microsoft Visual Studio - & | Quick Launch (Ctrl+Q) Pl o 0 x
File Edit View Project Debug Team  Tools Test  Analyze Window  Help

Deborah Fowler = m
io-o|f-UWM|2-C - - b Attach.. - | g7 _

Start Page + X

Modifying — Visual Studio Community 2017 — 15.4.5

x
Workloads Individual components Language packs
Windews-3) Summary
Visual Studio core editor
WM Universal Windows Platform development MET desktop development 4 ) )
.. Create applications for the Universal Windows Platform 'J Build WPF, Windows Forms, and console applications using > Universal Windows Platform development
with C#, VB, JavaScript, or optionally C++. C#, Visual Basic, and FZ. > Desktop development with C++

— o f‘ w Game development with Unity

Included
+ Visual Studio Tools for Unity
v C# and Visual Basic

I: Desktop development with C++
Build classic Windows-based applications using the power
of the Visual C+ = toolset, ATL, and optional features like... Optional
Unity 2017.1 64-bit Editor

Web & Cloud (7)

@ ASPNET and web development % Azure development
Build web applications using ASP.NET, ASP.NET Core, Azure SDK, tools, and projects for developing cloud apps
HTML, Java5cript, and container development tools. and creating resources.

ﬁ Python development @ MNode.js development

Editing, debugging, interactive development and source Build scalable network applications using Moedejs, an

control for Python. asynchronous event-driven JavaScript runtime.

Location
CA\Program Files (x86)\Microsoft Visual Studic\201 M\Community
TotaldnsfEll size:  1.45 GB

By continuing, you agree to the license for the Visual Studio edition you selactad. We also offer the ability to download other software with Visual Studio. This software )
is licensed separately, as set out in the 3rd Party Notices or in its accompanying license. By continuing, you also agree to those licenses. Maodify
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The following instructions apply to
VS 2017 or 2019
If different, they will be noted on the following slides

NOTE: In 2019 you no longer need to #include “pch.h”
(which used to be “stdafx.h” ... more later)
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)| Start Page - Microsoft Visual Studio

File Edit Viev Project Debug Team Tools Test Analyze
-oR-LEE[D-C-

StartPage & X

Get Started

Build your first app in 5 minutes!

Maximize your productivity with these tips and tricks for Visual
Studio

Take advantage of the newest technologies to deploy beautiful, low-
cost and reliable websites

Develop modern, fully-native, Android and i0S apps

Recent

Today
m ConsoleApplicationd.sin

C\Users\Deborah\source\repos\ConsoleApplicationd

m test.sin

C\Users\Deborah\source\repositest

ConsoleApplication2.sin
al ¢

sers\Deborah\source\repos\ConsoleApplication2

ConsoleApplication3.sin
@l i,

C\Users\D c\repos\ConsoleApplication

Error List

Entire Solution - [ 4 0Warnings || @ 0 Messages
" Code  Description

Package Manager Console [[Ziagted Output

7 Ready

6/26/2019

VS 2017

Window  Help

P Attach.. - | 5 _

Open

Get code from a remote version
control system or open something on
your local drive.,

Checkout from:

& Azure DevOps

2l Open Project / Solution

2| Open Folder

% Open Website

Search project templates
Recent project templates:

Windows Console...

Creste new project..

Build + IntelliSense -

Project

Developer News

Announcing MLNET 1.1 and Model
Builder updates (Machine Learning
for NET)

MLNET is an open-source and cross-
platform machine learning framework
(Windows, Linux, mac0S) for NET dev...
NEW Tuesday, June 25, 2019

Microsoft's MT-DNN Achieves
Human Performance Estimate on
General Language Understandi...
Understanding natural language is one
of the longest running goals of A,
which can trace back to 13505 when th
NEW Tuesday, June 25, 2019

Get Started with Free Xamarin
Training on Microsoft Learn

Leamn how to build cross-platform
mobile applications with the new
Xamarin.Forms cantent on Microsoft L.
NEW Tuesday, June 25, 2019

Faster Xamarin.Android Builds &
Smaller Dex Files

More news.

Search Error List

File

X | & | Quick Launch (Ctrl+Q)

Solution Explorer

| &

Solution Explorer

Properties

EHE

Team Explorer

P - O x

Deborah Fowler =

VS 2019

Visual Studio 2019

Open recent

o a
00'1 ConsoleApplicationd.sin
C:AUsers\Deborah\source\repos\ConsoleApplicationd
fa testsin /26/2019 200 PM -2
CAUsers\Deborah\source\repositest
m ConsoleApplication2sin /26/2019 2:30 PM
CA\Users\Deborah\source\repos\ConsoleApplication2
m ConsoleApplication3.sin /26/2019 1:31 PM
CAUsers\Deborah\source\repos\ConsoleApplication3
2] Mandelbrotuliasin 4/2/2019 8:11 AM
Y _Lectures\V375'Class11-14-OpenGL\Mandelbrotlulia\Mandelbrotlulia
] CcolorvisionGame.sin 3/25/2019 6:59 PM
Do\ ALECTURES\WSFX373-F13-LECTURES\ColorVisionGame\ColorVisionGame
fa] Mandelbrotiulia sin 3/25/2019 6:59 PM
ALECTURES\WSFX373-F13-LECTURES\Mandelbrotiulia\Mandelbrotlulia
an 135 /9 36 PM
00'1 ColorVisionGame.sin 3/25/2019 3:26 PM
A_Lec Class11-14-OpenG
-

www.deborahrfowler.com

Get started

2k, Clone or check out code

Get code from an online repository like GitHub
or Azure DevOps

Open a project or solution

Open a local Visual Studio project or sin file

it

-, Open a local folder
Mavigate and edit code within any folder

Create a new project

Choose a project template with code scaffolding
to get started



) start Page -3 Pt Visusl Studio

VS 2017

Window  Help

p Attach.. = | p% _

Y ﬂ:‘ Quick Launch (Ctrl+Q) Pl - ] x

Deborah Fowler =

~ | Solution Explorer -1 x

Edis giect Debug Team Tools Test Analyze
Get Start(™
b Recent
Build your first app in 3 ming 4 |nstalled
Maximize your productivity 4 4 Wfisual C++
Stud
e Windows Desktop
Take advantage of the newes b Cross Platform
cost and reliable websites MFC/ATL
Develop modern, fully-nativ Test
Other

b Other Project Types
> Onl

Recent |"™

Today

ConsoleApplicatior
k] o

sers\Deborah'so

il |

ConsoleApplicatior
: Deborahso

£

ConsoleApplicatior
C\Users\Deborahso

testsin Mot finding what you are leoking for?

£

Deborah'\sol

Open Visual Studio Installer

Sort by:

-
h Windows Console Application

Rti Empty Project

A
Windows Desktop Application

| C++

ConsoleApplication Name: [ConsoleApplication?

9

Location:

Solution name: ConsoleApplication?
Output

Show output from:

C:\Users\Deborah\source\repos -

Search (Ctrl+E) P~

Type: Visual C-+

A project for a command-line .exe
cation that runs an Windows,

«plarer

Browse...

Create directory for selution
D Add to Source Control

Package Manager Console Error List [[STaty

New Project can be
created two ways ...

Cancel

6/26/2019
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VS 2019

Create a new project

Recent project templates

Console App Crt

Search for project templates P~ Language ~ Platform - Project type

ﬁ Canscle App (NET Core)
O™ 4 project for creating a command-line application that can run on NET Core on
Windows, Linus and MacOS.

[ed Linux mac0s Windows Conscle

nic!" Class Library (NET Standard)
A project for creating a class library that targets NET Standard.
# Android 05 Linux

Er Empty Project
N

Start from scratch with C++ for Windows. Provides no starting files.

macQs Windows Library

C++ Windows

ﬁ' Canscle App

Run code in a Windows terminal. Prints "Hello World" by default.

Console

C++ Windows. Console

Windows Desktop Wizard

Create your own Windows app using a wizard.

C++  Windows  Deskiop  Conscle  Library

Windows Desktop Application
A project for an application with a graphical user interface that runs on Windows.

o Windows Desktop

Back



Presenter
Presentation Notes
Under the File menu select New then Project		


VS 2017 VS 2019

Configure your new project

Console App Cre Windows Conscle

Project name

Consolef\pplication’|

Location

‘ C:A\Users\Deborah\source\repos -

Solution name o

ConsoleApplication ‘

D Place solution and project in the same directory

6/26/2019 www.deborahrfowler.com 7



VS 2017 VS 2019

]  ConsoleApplication? - Microsoft Visual Studio X & | Quick Launch (Ctri+Q) P - B x
File Edit View Project Build Debug Team Tools Test Analze Window Help Deborah Fowler ~
-o|B-2@dE| 9 -0 | pebug -] 36 = P Local Windows Debugger - | 57 _° | -
ConsoleApplication7.cpp = % ~ | Solution Explorer -1 x
[ ConsoleApplication? -] (Global Scope) -l 3 GE-|B-5d@m| e ;E|
1 G/ ConsoleApplication7.cpp : This file contsins the 'main’ function. Program execution begins and ends there. +
5 LI’, PP il & & ‘; Search Selution Explorer (Ctrl+:) L~ 0¢ File Edit View Project Buld Debug Test Analze Tools Edensions Window Help  Search Visual Studio (Ctil-Q) » ConsoleApplication5. @ — o X
3 T # &1 Solution 'ConseleApplicationT' (1 project) cO B2 M| | ebug - a8 ~ P Local Windows Debugger ~ Auto M L] s & LiveShare &7
4 m#iglflide “pch.h” e A
5 [:i de <§Gstr‘Eam) 4 H 7 blution Explorer BN ConsoleApplicationS.cpp £ X §
M b =B References WE- o -5Sam o k= &) ConsoleApplications. -] (Globel Scope) -l §
7 Sint main() b g Extemal Dependencies Search Soluton Explore (Cti+) o 1 E\LV/ ConsoleApplicationS.cpp : This file contains the ‘main’ function. Program execution begins and ends there -
(crle > H
8 P £ HeaderFiles £ Solution ‘ConsoleApplications' (1 of 1 project) 3 -
a cout << "Hello World!\n"; Resource Files 4 [%) ConsoleApplication5 4 #include <iostream> g
b 4 SourceFiles b o0 e D int et £
e 1 v b 15 Extemal Dependencies 5 Eint main() .
b =l . tdiscout << "Hello world!\n"; g
12 E// Run program: Ctrl + F5 or Debug > Start Without Debugging menu e | e ello vorldiAn®s i
13 |// Debug program: F5 or Debug > Start Debugging menu b i Source iles I
14 11 E// Run program: Ctrl + F5 or Debug > Start Without Debugging menu
15 ©// Tips for Getting Started: E [/7 bebug program: 75 or Debug > Start Debugging menu
16 // 1. use the Solution Explorer window to add/manage files 14 @/ Tips for Getting Started
17 // 2. Use the Team Explorer window to connect to source control 15 |7/ 1. use the Solution Explorer window to add/manage Files
X . 16 J/ 2. Use the Team Explorer window to connect to source comtrol
s /1 3. Use the Output 'fmdmf to see h‘f‘lld output and other messages 17 // 3. Use the Output window to see build output and other messages
19 Ve 4. Use the Error List window to view errors 18 // 4. Use the Error List window to view errors
20 // 5. Go to Project > Add New Item to create new code files, or Preject > Add Existing Item to add existing code files tc 19|77 5. 6o to Project > Add New Item to create new code Files, or Project > Add Existing Item to add existing code Files to the project
21 // 6. In the future, to open this project again, go to File > Open > Project and select the .sln file ;i J/ 6. In the future, to open this project again, go to File > Open > Project and select the .sln file
22
Solution Explorer R g
Properties
=]z | #
100% - @ Noissues found
Output -3
Show output from:  IntelliCode. - [ & 2
- [VSIX I] Trace log: C:\l Data\locall’ ip\ IntelliCodelogs\20190626_193819_VS.log
el 5 [VSTX 1] Version: 2.2.182.4585
Output - 1>
Show output from: -l & | % | =a
Solution Bxpl.. w  Property Man... Team Explorer [l Error List
B ez S tn1 col1 cn s
Package Manager Console Error List [Jeiuaty
[ Creating project ‘ConsoleApplication7"... project creation succ Ln 1 Col 1 Chl INS 4 Add to Source Control =

6/26/2019 www.deborahrfowler.com 8



VS 2017 Now you have the screen where you VS 2019
will type in your program

4] ConsoleApplications - Microsoft Visual Studio | & | Quick Launch (Ctri+0) Pl - o x D) File Edit View Project Bulld Debug Test Analyze Tools [Extensions Window Help  Search Visual Studio (Cirl+0) £ | ConsoleApplicationd ® - o x
File Edit View Project Build Debug Team Tools Test Analyze Window Help Deborah Fowler ~ = ‘ [N ] dﬂ‘ B | Debug - x26 ~ B Local Windows Debugger - Auto S | S | = ‘ n - & LiveShare g7
-o|l@-a |9 - @ <[ Debug -||xe6 = P Local Windows Debugger - | 51 _i ig ”
Solution Explorer BN Consolespplicationd.cpp # X %
ConsoleApplication8.cpp & X < @ B -‘ -5 a8 @| O S m [ ConsoleApplicationd -| (Global Scope) -| ;
% ConsoleApplications -l (Global Scope) -1 g AE-|o-5a@d| o IE . 1 @)/ ConsoleApplicationd.cpp : This file contains the 'main’ function. Program execution begins and ends there. s
1 B/ ConsoleApplications.cpp : This file contains the 'main’ function. Program execution begins and ends there B3 Sorch Solation Exalorer (Cin 3 Search Solution Explorer (Crl+) p- [1s H
2 _a g oearcncotion Bxplorer ¥ ) 1 Solution 'ConsoleApplicationd’ (1 of 1 praject) 3 ;
3 R Solution 'ConsoleApplication8' (1 project) 4 [§] ConsoleApplicationd 4 #include <iostream> B
: E‘G%M}“:E A 4 P4 ConsoleApplicationd b wm References s g
include <iostream : : g
. b wm References b FE Extemal Dependencies j Sint main()
. . b 5 External Dependencies 7 3
7 Eint main() Y leade bl s std:zcout << "Hello World!\n"; 3
s b 5 Header Files 7 Resource Files o 3 E
9 std:zcout << “Hello World!\n"; +4 Resource Files b g SourceFiles 10 ®
10 3 b s Source Files .
- 11 E// Run program: Ctrl + FS or Debug > Start Without Debugging menu
11
12 // Debu rogram: F5 or Debug > Start Debugging menu
12 B©// Run program: Ctrl + F5 or Debug > Start Without Debugging menu - L & Prog & 88218
13 | /7 Debug program: FS or Debug > Start Debugging menu 14 [E// Tips for Getting Started:
= . . 15 /I 1. Use the Solution Explorer window to add/manage files
b Eﬁ Tipe for i;;‘;zii:;t:xélwer \indon o addfmsnage Files 16 // 2. Use the Team Explorer window to connect o source control
. ) 2‘ Use the Tesn Explorer window to connect e source control 17 // 3. Use the Output window to see build output and other messages
. . . 18 // 4. Use the Error List window to view errors
1: ;;‘ i‘ EZ ::Z g::sﬁ:‘:zzd;‘l‘n;zwsi: 5::\1:1223? and other messages 19 // 5. Go to Project > Add New Item to create new code files, or Project > Add Existing Ttem to add existing code
0 // 5. Go to Project > Add New Item to creste new code files, or Project > Add Existing Ttem to add existing code files to the project 2 /1 6. In the future, to open this project again, go to File > Open > Project and select the .sln file
21 // 6. In the future, to open this project again, go to File > Open > Project and select the .sln file 2
22
Solution Explorer [FENRE I
Properties
| &
100% - @ No issues found 4 »
Output Output -0 x
She outpat rom: Show output from: Debug Sl | &
‘ConsoleApplication9.exe’ (Win32): Loaded 'C:\Windows\SysWOW64\imm32.d1l'.
The thread @x48cc has exited with code @ (@x8).
The thread @x39bc has exited with code @ (@x8).
The thread @x3bac has exited with code @ (@x8).
The thread @x3cb@ has exited with code B (@x@).
The program '[11632] ConsoleApplicationd.exe' has exited with code 8 (@x8).
e — 5les Solution Expl.. LR L output [
Package Manager Console Error List [ p perty P b

[J Creating project 'ConsoleApplication8'... project creation successful. Add to Seurce Control « L7 Ready Ln1 Ch1 INS 4 Add to Source Control « &

fyt

6/26/2019 www.deborahrfowler.com 9



VS 2017 ONLY

* pch.h - is a precompiled file (all things above it are
assumed precompiled)

* Unique to Visual Studio (take it out if not using VS/ add it
If using VS2017 — not required in VS2019)

* Includes precompiled files that are frequently used and
rarely changed

6/26/2019 www.deborahrfowler.com
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Now type in your first program

www.deborahrfowler.com
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#include "pch.h"

[/ Vs2017

#include <iostream>

int main()

{

std: :cout << "Hello World!\n";

6/26/2019

#include <iostream>

1int main()

1
¥

std::cout << "Hello World!\n";

www.deborahrfowler.com
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#include "pch.h™ f/ V52017
_#iﬂclude £l1ostream?>

lint main()

{
std: :cout << "Hello World!in";
f/ Only required if you go to Tools/Options/Debugging
f/ Automatically close the console when debugging stops
std::cout << "Press Enter or Return to Exit";
std::cin.get();
// Is accurate, indicates to the 05 that main functioned correctly
return @;
T

6/26/2019 www.deborahrfowler.com
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;’QJ ConsoleApplication8 - Microsoft Visual Studic ¥ | 5  Quick Launch (Ctrl+Q) Pl - ] x

File Edit View Project Build ols  Test  Analyze  Window  Help Deborah Fowler ~ I

= | F-2 A ml - p LocalWindowsDebuggervl B | | [ e’ By | =

Solution Explorer
QE- -5 B o L=

Search Solution Explorer (Ctrl+;)

7

a1 Solution 'ConsoleApplicationd' (1 project)

. N N 4 [%] ConsoleApplication8
E#include "pch.h [/ vs2e17 b = References

L#include <iostream?> b 5 External Dependencies
b 57 Header Files
=lint main() £ Resource Files
{ 4! Source Files

std::cout << "Hello World!\n";

=// Run program: Ctrl + F5 or Debug > Start Without Debugging menu
// Debug program: F5 or Debug > Start Debugging menu

=/f/ Tips for Getting Started:
1. Use the Solution Explorer window to add/manage files
Use the Team Explorer window to connect to source control
Use the Output window to see build output and other messages selution Brplerer | o fo o
Use the Error List window to view errors Properties
. Go to Project > Add New Item to create new code files, or Project > Add Existing Ite

In the future, to open this project again, go to File > Open > Project and select th

Output

Show output from: Build - | | | = | %a

—————— Rebuild All started: Project: ConsoleApplicationg, Configuration: Debug Win32 ------
1»pch.cpp
1:>ConsoleApplicationd.cpp
13ConsolefApplication8.vexproj -»> C:\Users\Deborah\source\repos\ConsoleApplication8\DebughCy

========== Rebuild All: 1 succeeded, 8 failed, @ skipped ========== ShOWS |t Worked Correctly

Package Manager Console Error List [RET{:I04

[7 Rebuild All succeeded | A Add to Source Control «

6/26/2019
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Run the program by selecting Start Debugging from the Debug pull-down
menu. If it is out of date it will ask “do you want to build your project *
(invokes compiler) (or run by pressing the green
arrow)

ﬂ Consolefpplication8 - Microsoft Visual Studi X & | Quick Leunch (Ctrl~Q) P - B x
“w  Help Deborah Fowler ~

File  Edit View Project Build Debug  Team tomis ~ Test  Analyze
g - | [l - | d"| - -| Debug ~ x86 - p LocalWlndowsDebuggerv‘ oo | ?

0]

ConsoleApplication8.cpp ® X > 1 x

1|

2 %] ConsoleApplications - (Global Scope) ~ @ main() - @& & -| m-5 & r@| < ﬁIEI
1 -1// ConsoleApplication8.cpp : This file contains the 'main' function. Program execution beginf Search Solution Explorer (Cri+:) p-
; 4 ] Selution 'ConsoleApplicationd' (1 project)
4 —#include “pch.h" [/ VS2017 : F_c:r:::::::ﬂmns
5 #include <iostream> — b 1z External Dependencies
6 b 5 Header Files
7 =lint main() 4 Resource Files
8 { b 57 SourceFiles
g std::cout << "Hello World!\n";

18 :
11
12 -1// Run program: Ctrl + F5 or Debug > Start Without Debugging menu
13 // Debug program: F5 or Debug > Start Debugging menu
14
15 -// Tips for Getting Started:
16 Iy 1. Use the Solution Explorer window to add/manage files
17 // 2. Use the Team Explorer window to connect to source control
18 // 3. Use the Output window to see build output and other messages Selution Bxolorer | Iz 7 e
19 // 4. Use the Error List window to view errors
28 Iz 5. Go to Project > Add New Item to create new code files| ® Microsoft Visual Studie Debug Console
6. In the future, to open this project again, go to File[jENSGRIGIIEH ~

Show output from: Debug M | | =M

'ConsoleApplication8.exe' (Win32): Loaded 'C:\Windows\SysWOW64\imm32.dll'. Cannot find or [d close this window .
The thread 8x2384 has exited with code @ (8x8).

The thread @x3688 has exited with code @ (8x@).

The thread @x1854 has exited with code @ (8x8).

The thread @x3b58 has exited with code @ (@x8).

The program '[9872] ConscleApplication8.exe' has exited with code 8 (@x@8).

Package Manager Console Error List [(el#4

4 Add to Source Control =

6/26/2019 www.deborahrfowler.com



Now let’'s examine the code:

;‘ﬂ Consclefpplication® - Microsoft Visual Studic
File Edit View Project Build Debug Team  Tools Test Analyze Window  Help
” | -2 WM | - = | Debug ~-| xB6 -~ P Local Windows Debugger v| 5 _ihy | )

il
i

4l

-

Consclefpplication8.cpp # X
(%] ConsoleApplicationd vI (Global Scope)
TI! ConsolefApplication8.cpp : Thj

[/

-I © mainf)
le contains the 'main' function. Program execution b

C++ provides ways to do
input/output
#include tells the pre-processor this
Fint main() is from a standard library

{
9 std: :cout << "Hello World!h

B

S#include "pch.h" // VS2g
L#iﬂclude <lostream?>

=// Run program:
SEERRLERL RS C++ programs have a function called main() which is the starting point

int main() - is a function

A function is a group of programming code that does some work
and returns a value (returns 0 if successful).

6/26/2019 www.deborahrfowler.com
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Eﬂ Consolefpplication® - Microsoft Visual Studio
File Edit View Project Build Debug Team  Tools Test Analyze Window  Help
= | i3 -2 W | - = | Debug =~ x86 ~ P Local Windows Debugger v| o : e | )

i
i
|

Consclefpplication®.cpp + X
%] ConsoleApplicationd - I
=// ConsoleApplication8.cpp : This fil

1/

(Global Scope) vll'fi main()
ontains the "main' function. Program execution b

=#include "pch.h’
_#iﬂclude <iost

Fint main()
{

std::cout << " World!Yyn™;

}

P ® W0 2 = W P R

b 2

ing menu

std is the namespace (like a phone number’s area code)
scope resolution operator

Note that statements end in a semicolon in C++
Will print what is in the quotation marks (string literal)

6/26/2019 www.deborahrfowler.com
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_;'ﬂ ConsoleApplicationd - Microsoft Visual Studio
File  Edit View  Project Build Debug Team  Tools Test  Analyze Window  Help
| i3 -2 W G | - = | Debug =~ x86 + P Local Windows Debugger v| I _ihg | §

[}
it

L1

=l ConsoleApplication8.cpp & X
=] | Consolefpplicationd vI (Global Scope) vlﬂ‘fl rnain()

1 =/ Consolefpplication8.cpp : This file contains the 'main' function. Program execution b
2 |

3

4 S#include "pch.h™ /7 V52817

5 L#include <iostream>

5]

7 =jgt main()

8

9 std::cout << "Hello World!\n";

1@

Run program: Ctrl + F5 or Debug > Start Without Debugging

Note that the main() function body (group of statements) is

surrounded by curly braces - this defines a block
Coding standards for this class will have these lined up as above

www.deborahrfowler.com 18



Coding Standards

What are coding standards®? All code written in class
or on the job must conform to coding standards (the
use of naming conventions and whitespace —

formatting — of the program)

This is not the same as syntax — the rules to construct
a legal statement or expression

6/26/2019 www.deborahrfowler.com
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6/26/2019

A complete list of the coding standards can be found on

the class website — these will be mentioned as we
introduce items as well

www.deborahrfowler.com
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;-9] Consclefpplication - Microseft Visual Studio
File Edit View  Project Build Debug Team  Tools Test Apalyze Window  Help

- | HR-2 W w| - = | Debug ~-| =26 = P Local Windows Debugger v| B ; =) | = = | | =
Consclefpplication8.cpp ® X
%] ConsoleApplicationd vI (Global Scope) vlffi rmain)
1 =// Consolelpplication8.cpp : This file contains the 'main' function. Program execution b
2|
3
4 #include “pch.h" // Vs2817
5 #include <iostream>
. i
7 Fint main()
8 {]
g std::cout << "Hello World!\n";
0

In C++, you can use the keyword “using” and namespace to avoid
having to type “std::” each time we use cout and cin
Example: using namespace std (called a using directive)
Example: using std::cout (called a using declaration)

6/26/2019 www.deborahrfowler.com 21



Eﬂl Consolefpplicationd - Microsoft Visual Studio ¥ | & | Quick Launch (Ctrl+Q) Pl - O x
File Edit View Project Build Debug Team Tools Test Analyze Window Help Deborah Fowler = [l
< | B-2 W | - - | Debug ~ x86 ~ P Local Windows Debugger - | g _ & | | | _

ConsoleApplication8.cpp + X Solution Explorer
¥ ConsoleApplicationd - (Global Scope) ~ @ main() - @ & -| oS J r@| < ﬁEI
-1// Consolefpplication8.cpp : This file contains the 'main’' function. Program execution bel+

I -

ubelg

0] 1y

Search Solution Explorer (Ctrl+;)

fa] Solution 'ConsoleApplication®' (1 project)
. 4 [%] ConsoleApplication8
—i#include "pch.h™ // VS2017 b =B References
#include <iostream> b 5 External Dependencies
using namespace std; b Header Files
Resource Files

—lint main() Source Files
{ p @ ConscleApplication8.cpp

WO s U Bl R e

cout << "Hello World!\n";

=// Run program: Ctrl + F5 or Debug > Start Without Debugging menu
// Debug program: F5 or Debug > Start Debugging menu

-// Tips for Getting Started:
17 1. Use the Solution Explorer window to add/manage files
Use the Team Explorer window to connect to source control solution Explorer RECINEtlEy
Use the Output window to see build output and other messages Properties
Use the Error List window to view errors ConsoleApplication8.cpp File Properties
Go to Project » Add New Item to create new code files, or Project > Add Existing

In the future, to open this project again, go to File » Open > Project and select ™
»
ConsoleApplication8.cpp

Output Content False

Show output from:  Debug = | | | §| a File Type C/C++ Code

'ConsoleApplicationB8.exe’ (Win32): Loaded 'C:\Windows\SysWOW64\imm32.d1l'. Cannot find or open the PDB file. Full Path Ch\Users\Deborah\source\repos),
The thread 8x132c has exited with code @ (8x8). Included In Project True

The thread 8x1d88 has exited with code @ (8x@).

The thread 8x3714 has exited with code @ (8x8).

The thread @x1758 has exited with code @ (@x8).

The program '[7248] ConsoleApplication8.exe' has exited with code @ (@x8).

Relative Path ConsoleApplication8.cpp

(Name)
Mames the file object.
Package Manager Console Error List [JIT#0

[T Ready | 4 Addto Source Control =

6/26/2019 www.deborahrfowler.com



Egl ConsoleApplication8 - Microsoft Visual Studio ¥ &  Quick Launch (Ctrl+Q) Pl = O x

File Edit View Project Build Debug Team Tools Test Analyze Window Help Deborah Fowler ~ [&
Q- | B2 W d"| - = | Debug =~ x86 = P Local Windows Debugger = | &

il

ConsoleApplication8.cpp # X Solution Explorer
¥ ConsoleApplicationd (Global Scope) @& & ,| o5 & r@l Fes ﬁEI
=/ Consolefpplication8.cpp : This fj tains the "main' function. Program execution b

VZ

¥0Q|oo)] [

0] 135

Search Solution Explorer (Ctrl+;)

fal Solution 'ConscleApplication8' (1 project)
) 4 [%] ConsoleApplication8
E#include "pch.h™  /f/ vs2 b =B References
L#include <ilostream> b 15 External Dependencies

using namespace std; p Header Files

Resource Files

Dint main() Source Files
{ »  4m ConsoleApplicationd.cpp

cout << "Hello World!\n";

E// Run program: Ctrl + F5 or Debug > Start Without Debugging menu
// Debug program: F5 or Debug > Start Debugging menu

E/f/ Tips for Getting Started:

Iz 1. Use the Solution Explorer window to add/manage files
Solution Explorer [REEug=nIbIE

. Use the Team Explorer window to connect to source control
. Use the Output window to see build output and other messages Properties
. Use the Error List window to view errors ConsoleApplication8.cpp File Properties
. Go to Project > Add New Item to create new code files, or Project > Add Existing

In the future, to open this project again, go to File > Open > Project and select ™

ConsoleApplication8.cpp
Output

R Comments in C++ are

'ConsoleApplication8.exe' (Win32): Loaded 'C:‘\Windows\5

The thread @x132c has exited with code @ (@x@).

The thread @x1d88 has exited with code @ (@x@). //
The thread @x3714 has exited with code @ (éxe).

The thread 8x1758 has exited with code @ (8x@8).

The program [7240] ConsoleApplications.exe: has exited You may see older C-style /* */
Just like whitespace (tabs, spaces, newlines),
o Ready ignored by the compiler, there to make code
more readable

6/26/2019 www.deborahrfowler.com



Eﬂ ConscleApplication® - Microsoft Visual Studic

File  Edit
Le-

View  Project  Build Debug
|B-aRH|2 - -

Consolefpplication8.cpp # X
%] ConsoleApplication8

-1// ConsoleApplication8.cpp : This file contains the 'main' function. Program execution be+

/o

—i#include "pch._h"

Team  Tools Test Analyze Window  Help
Debug - =86 = P Local Windows Debugger = | &

Solution Explorer
-\ (Global Scope) -1 ® maing) dE- -5

" Search Solution Explorer (Ctrl+;)
a1 Solution 'ConsoleApplicati
4 [%] ConsoleApplication8
/1 vs2017 [» =B References

#include <iostream> P Iz External Dependenc

using namespace

—int main()

{

std; Header Files
Resource Files
Source Files

¥ & | Quick Launch (Ctrl+Q) Pl - [m]

Deborah Fowler =

E‘!T'F@|<>)E

ond' (1 project)

ies

& ConsoleApplication8.cpp

*++ pch.cpp

cout << "Hello World!\n";

-// Run program:

Ctrl + F5 or Debug > Start Without Debugging menu

// Debug program: F5 or Debug > Start Debugging menu

-// Tips for Getting Started:

I’ 1. Use the
I’ . Use the
I’ . Use the
I’ . Use the

Output

Show output from: Debug

'Consolefpplication8.exe' (Win32):

The
The
The
The
The

thread 8x132c has exited with
thread 8x1d88 has exited with
thread 8x3714 has exited with
thread 8x1758 has exited with
program '[7248] ConsoleApplic

Solution Explorer window to add/manage files

Team Explorer window to connect to source control
Output window to see build output and other messages Properties
Error List window to view errors ConsoleApplication8.cpp File Properties
Go to Project > Add New Item to create new code files, or Project > Add Existing

In the future, to open this project again, go to File » Open > Project and select ™
3

Content
- | | | £ | ®a File Type
Loaded 'C:\Windows\SysWOW64\imm32.d11'. Cannot find gg open the PDB file. Full Path
code 8 ngeg . Included In Project
code 8 (8x8). .
code @ (@x@). Relative Path

code @ (@x@). ThiS iS Okay

ation8.exe' has exited with code 8 (8x@).
(Name)

eXit normal Mames the file object.

Package Manager Console Error List R0

[ ] Ready

6/26/2019
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Solution Explorer [EETRESILIEY

ConscleApplication8.cpp

False

C/C++ Code
ChUsers\Deborah\source\reposh
True

ConscleApplication2.cpp

4 Add to Source Control a

X

DF

ubeig

21350

i
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;'QJ ConsoleApplicationd - Microsoft Visual Studio

File  Edit View

3
2

Project  Build
O | B-m P
ConsoleApplication8.cpp ® X

2 ¥ Consolefpplicationd

Debug Team Tools Test Analyze Window Help

- | Debug ~ x86 - p LocalWindowsDebuggerv|p

- (Global Scope) ~ @ main()

¥ | &'  Quick Launch (Ctrl+Q) Pl - B >

Deborah Fowler ~ [®3 |

~ | Solution Explorer

~ QEIJ'|'G)":.|§IT'FE11|<>)E

[ R R L S

Error List

Entire Solution
* Code

28 EDDES
€2 2146
€ caoes

=// Consolefpplication8.cpp : This file contains the 'main' function. Program execution be+

V7

E#include "pch.h™ // VS2017
L#include <iostream>
using namespace std;

=int main()

{

cout whoops << "Hello World!\n";

3

=/ Run program: Ctrl + F5 or Debug > Start Without Debugging menu
L// Debug program: F5 or Debug > Start Debugging menu

=/f/ Tips for

/1.
/2.
/3.
/A
// 5.

6.

- ||(3 3 Errors ||| 1 0Warnings || 0 0Messages

Description
expected a '}’

syntax error: missing ;' before

Use
Use
Use
Use

Go to Project > Add New Item

Getting Started:

the Solution Explorer window to add/manage files

the Team Explorer window to connect to source control
the Output window to see build output and other messages
the Error List window to view errors

Search Error List

identifier 'whoops'

‘whoops" undeclared identifi

Package Manager Console [J3gslgRid

[ Build failed

Project

www.deborahrfowler.com

to create new code files, or Project > Add Existi
In the future, to open this project again, go to File » Open > Project and select ™ —

2,
A
=y

Search Solution Explorer (Ctrl+;) R -

5|

fa] Solution 'ConsoleApplication8' (1 project)
4 [%] ConsoleApplication8

P =B References

b g External Dependencies

b 2 Header Files
57 Resource Files
4 .| Source Files
P ++ ConsoleApplication8.cpp
*++ pch.cpp

Always fix the first error and re-build —
(trying to be helpful it often generates
a list after the first problem)

4 Add to Source Control «

25



Eﬂ Consolefpplicationd - Microsoft Visual Studio X &' | Quick Launch (Ctrl+Q) P - B x
File  Edit View Project  Build Debug Team  Tools Test Analyze Window  Help Deborah Fowler = [BlE |
- | -2 . wl - - | Debug ~ x86 + P Local Windows Debugger v| A ; =] | | | =
E ConsoleApplication8.cpp # X * | Solution Explorer 1 x 'E:
:':"'._ [%] ConsoleApplication® - (Global Scope) ~ @ main() - =" ,| w5 8 r@| < ﬁEI .f:}
. 5 - . . . P . . * A
; —;i ConsoleApplication8.cpp : This file contains the 'main' function. Program execution belT Search Solution Explorer (Ctrl+:) Iy -
3 fad Solution 'ConsoleApplicationd' (1 project) &
] B y 4 [%] ConsoleApplication8

il —ﬂJI.nclude ?ch.h [/ vs2817 b &E References

5 #include <iostream> b g External Dependencies

6 using namespace std; b = Header Files

7 5| Resource Files

a —int main() 4 .| Source Files

g { b ++ Consolefpplication8.cpp

++ pch,

18 cout << "Hello World!\n" pencep

u |}

12

13 =// Run program: Ctrl + F5 or Debug > Start Without Debugging menu

14 // Debug program: F5 or Debug > Start Debugging menu READ THE ERROR MESSAGE

15

16 -// Tips for Getting Started:

17 I 1. Use the Solution Explorer window to add/manage files

. Solution Explorer [EETNSEALTES

18 7 2. Use the Team Explorer window to connect to source control

19 I/ 3. Use the Output window to see build output and other messages Properties

28 7 4. Use the Error List window to view errors

21 Il 5. Go to Project > Add New Item to create new code files, or Project > Add Existing

7 6. In the future, to open this project again, go to File » Open > Project and select ™

Error List

Entire Solution - ||E32Errors ||| 1 0Warnings || © 0 Messages || Build + IntelliSense -
" Code  Description Project File Line |Supprg

Search Error List

A OE0DBS  expecteda )’ Consolefpplicationd Consolefpplication8.cpp 11

0 o142 consoleapplication.cpp 11 For example, a miSSing SemiCO|0n

syntax error: missing ;' before ') ConsclefApplication®

Package Manager Console JGUNCS Output

7 Build failed 4 Addto Source Control =

a [

6/26/2019 www.deborahrfowler.com
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EQJ ConsoleApplication® - Microsoft Visual Studic ¥ 57 | Quick Launch (Ctrl+Q) Pl ]
File  Edit View Project Build Debug Team  Tools Test Analyze Window  Help Deborah Fowler -
e~ | H-2 W f| 2 - -| Debug =~ x86 = P Local Windows Debugger v| B ; =] | E % | | -
E ConsoleApplication8.cpp 7 X ¥ | Solution Explorer v o X
FEF @Consoleﬁ\pplications - (Global Scope) ~ @ main() - f:.'f & _l v@ -5 g @| < }'E
: : - - : : —— : : =
; - 5;’ ConsolefApplication8.cpp : This file contains the 'main' function. Program execution be—i— Search Solution Explorer (Ctrl+) P-
3 fa] Solution 'ConsoleApplicationd' (1 project)
) N " 4 [%] ConsoleApplication8
4 —!*Jl_nclude [.JCh.h /] V52017 b =B References
5 #include <iostream> b g External Dependencies
6 using namespace std; b 2 Header Files
7 4+ Resource Files
] —int main() Source Files
9 ) ConsoleApplicationd.cpp
i h.
10 cout << "Hello World!\n" Click on the error, takes you to the (g8
- 11 i c 1 E
12 line of proximity to the error
13 -1// Run program: Ctrl + F5 or Debug > G CDWE L TE o
14 // Debug program: F5 or Debug > Start B gging menu
15
16 -1// Tips for Getting Started:
17 [/ 1. Use the Solution Explorer window to add/manage files ]
18 I/ 2. Use the Team Explorer window to connect to source control solution Explorer [RECUYSRIELY
19 // 3. Use the Output window to see build output and other messages Properties
20 I/ 4. Use the Error List window to view errors
21 // 5. Go to Project > Add Mew Item to create new code files, or Project > Add Existing
22 I/ 6. In the future, to open this project again, go to File > Open > Project and select ™
121% = 4 4
Error List > I X
Entire Solution - ||Q 2 Errors ||| 1 0Warnings ” ) 0 Messages || Build + IntelliSense - Search Error List P~
* Code Description Project File Line  Suppression State
2 OEODBS  expecteda Consolefpplicationd ConsoleApplication8.cpp 11

consoleapplication8.cpp 11

€ a3 syntax errer: missing ;' before '} ConsoleApplicationg

Error List

Package Manager Console Qutput

L[] error C2143: syntax error: missing ;' before '}’ Ln 11 Col1 Ch1 INS 4 Add to Source Control «

6/26/2019 www.deborahrfowler.com
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EQJ ConsoleApplication8 - Microsoft Visual Studio ¥ | & | QuickLaunch (Ctrl+Q) P - B x

File  Edit View Project Build Debug Team Tools Test Analyze Window Help Deborah Fowler = [Bl3
o2 M| D -] Debug - 386 -~ P Local Windows Debugger ~ | 51 _ 2 g = | = %= [ W =
E Conselelpplication8.cpp + X > | Selution Explorer
8 ¥ ConseleApplications vI (Global Scope) vlﬁl main() - @ & ,| mr5 & @| < }.E
- : - - : : —— : : Tx
; EL;ﬁ Consolefpplication8.cpp : This file contains the 'main' function. Program execution b 1_ Search Solution Explorer (Ctrl+:)
3 fa] Solution 'ConsoleApplicationd' (1 project)
. " " 4 [%] ConsoleApplication8
4 E#include "pch.h /{ vs2017 b =B References
5 L#include <iostream> b I3 External Dependencies
6 using namespace std; b 27 Header Files
7 4 Resource Files
3 =int main() ;
9 {
10 cout << "Hello World!\n"; 1 f 1 1
o 1 d Fix the first error — compile or run again — success!

12
13 =// Run program: Ctrl + F5 or Debug > Start Without Debugg
14 L// Debug program: F5 or Debug > Start Debugging menu

15

16 =lf/ Tips for Getting Started:

17 [/ 1. Use the Solution Explorer window to add/manage files

18 7 2. Use the Team Explorer window to connect to source control Solution Explorer QLI L)
19 // 3. Use the Output window to see build output and other messages Properties

28 17 4. Use the Error List window to view errors

21 I/ 5. Go to Project > Add New Item to create new code files, or Project > Add Existing E’-I; |;"

22 7 6. In the future, to open this project again, go to File » Open > Project and select ™

21% ~ 4 »

Output * 0 x
, *= | ab
Show output from:  Debug S = | cd

'ConsoleApplicationd.exe’ (Win32): Loaded 'C:‘\Windows\SysWOW64'\imm32.d1l'. Cannot find or open the PDB file.
The thread 8x3f@4 has exited with code @ (8x@).

The thread 8x4194 has exited with code @ (Bx@).

The thread @xe54 has exited with code @ (8x@).

The thread 8x8f@ has exited with code @ (8x@).

The program '[17288] ConsoleApplication8.exe' has exited with code @ (@x@).

Package Manager Console Error List [T 03

L[] Ready Col 30 h 27 4 Add to Source Control =
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If you are working in VS 2017 or VS 2019
Community
a build (compile) and run will look as follows

www.deborahrfowler.com
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Eﬂ ConscleApplication - Microsoft Visual Studic
File  Edit View Project Build Debug Team Tools Test Analyze Window  Help
- | ﬁj -2 W w| - x86 = P Local Windows Debugger v| A _ =) | | I e B | =

(Global Scope) - @ main()

This file contains the 'main' function. Program execution be{s
FY

—i#include "pch.h"
#include <iostream>
using namespace std;

—lint main()

{
cout << "Hello World!\n";

—f/ Run program: Ctrl + F5 or Debug > Start Without Debugging menu
// Debug program: F5 or Debug > Start Debugging menu

-1// Tips for Getting Started:

7 1. Use the Solution Explorer window to add/manage files

Iy . Use the Team Explorer window to connect to source control

I/ . Use the Output window to see build output and other messages

Iy . Use the Error List window to view errors

/7 . Go to Project > Add New Item to create new code files, or Project > Add Existing

7 . In the future, to open this project again, go to File * Open > Project and select™
3

Output

Show output from:  Build - | | | = | ma
Rebuild A1l started: Project: Consolefpplication8, Configuration: Debug Win32

1xpch.cpp
1>Consol einnlieemEemmppp—

onsoleApplication8.vexproj -> C:\Users\Deborah\source\repos Application8\DebugiConsoleApplications.exe
Rebuild All: 1 succeeded, @ failed, @ skipped ===

Package Manager Console Error List el

7 Rebuild All succeeded

6/26/2019 www.deborahrfowler.com

¥ & | Quick Launch (Ctrl+Q) P - jm]

Deborah Fowler ~

Solution Explorer
BE-|o-5saBd| o L=
Search Solution Explorer (Ctrl+;)

fad Solution 'ConsoleApplicationd' {1 project)
4 %] ConsoleApplication8

I =B References

I Fg External Dependencies

I Header Files
Resource Files

*
*
£, Source Files

+3+ Consclefpplication8.cpp
++ pch.cpp

Solution Explorer BEETANSTTES

Properties

4 Add to Source Control =

x

[

F
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_‘ﬂl ConsoleApplicationd - Microsoft Visual Studio

File

Xog|oo|

=

6/26/2019

¥ | &  Quick Launch (Ctrl+Q) Pl - [ 4

Edit View Project Build Debug Team  Tools Test Analyze Window  Help Deborah Fowler ~
- -2 D~ = | Debug = 86 - P Local Windows Debugger ~ | 57 _ == N -
Consolefpplicationd.cpp # X ~ | Solution Explorer = E
%] ConsoleApplication - (Global Scope) = @ main() - GEl- m-saml| e }.EI a
- . - ) . . P . . s =
! —;; ConsoleApplication8.cpp : This file con ain' function. Program execution be—i— Search Solution Explorer (Ctrl+) »-
£ [=]
- f] Solution 'ConsoleApplicationd' (1 project) &
- L 4 [%] ConsoleApplication8
4 —i#include "pch.h" f/ vs2817 b e References
5 #include <iostream> B 15 External Dependencies
6 using namespace std; — b 2 Header Files
7 20 Resource Files
8 —Jint main() B Microsoft Visual Studio Debug Console
9 { Hello World!
18 cout << "Hello 'nlor*ld!\,n";[
11 LRl
12 ! sole when c
13 —1// Run program: Ctrl + F5 or Debug > Start Without Debugging menu this window
14 // Debug program: F5 or Debug > Start Debugging menu
15
16 -// Tips for Getting Started:
17 Iy 1. Use the Solution Explorer window to add/manage files
18 Iy 2. Use the Team Explorer window to connect to source control
19 // 3. Use the Output window to see build output and other messagesd
28 I 4. Use the Error List window to view errors
21 // 5. Go to Project > Add New Item to create new code files, or P
22 7 6. In the future, to open this project again, go to File > Ope
121% ~| 4

Show output from:  Debug - € | ™a

The thread @x349c has exited with code @ (8x8).
The thread 8x3b44 has exited with code @ (8x8).
The thread @x6co b L L Code © (exd).
The thr; ®32f4 has exited with code @ (Bx8).
The th&gad @x23e® has exited with code @ (8x8).
The progra ConsoleApplication8.exe' has exited with code 8

Package Manager Console  Error List [RIV4T}3

I ——
Ready Ln 10 3 4 Add to Source Control =

www.deborahrfowler.com
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Congratulations! You have written a successful C++
program using Visual Studio 2017

Or Visual Studio 2019 Community

6/26/2019 www.deborahrfowler.com
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E'_QJ ConsoleApplicationd - Microsoft Visual Studio X & Quick Launch (Curl+Q) Pl - 0O

File Edit View Project Build Debug Team  Tools Test Analyze Window  Help Deborah Fowler ~
- | fi R~ | m| 92 - -| Debug ~| xB6 ~ P Local Windows Debugger v| B

[
hii
i
b |
1

ConsoleApplication8.cpp & X Solution Explorer
%] ConsoleApplication® - (Global Scope) - @ main() & & -l o5 & r@| < ﬁE

-1// ConsoleApplication8.cpp : This file contains the 'main' function. Program execution bel
a

/1l
fal Solution 'Consolefpplicationd' (1 project)
) N N 4 %] ConsoleApplication8
—i#include "pch.h [/ vs2017 b = References
#include <iostream> B 15 External Dependencies

Xog|oo]| [EeE

Search Solution Explorer (Ctrl+;)

using namespace std; b 27 Header Files
Resource Files

Solution Explorer — double click " SomecFles

k2

I *+ Consclefpplication8.cpp

e on your source if it doesn't ~ bchepp
display when re-opening your
-1// Run program: Ctrl prOJeCt

// Debug program: F5

—lint main()

LN R B o Y I Y

-// Tips for Getting Started:
Iy 1. Use the Solution Explorer window to add/manage files
Iy . Use the Team Explorer window to connect to source control
I/ . Use the Output window to see build output and other messages Properties
Iy . Use the Error List window to view errors
. Go to Project > Add Mew Item to create new code files, or Project > Add Existing
In the future, to open this project again, go to File > Open > Project and select ™

Solution Explorer EETRNSE

Output

Show output from:  Debug - | | | & a

'ConsoleApplication8.exe’ (Win32): Loaded 'C:\Windows\SyskOW64\imm32.d11l'. Cannot find or open the PDE file.
The thread 8x3f@4 has exited with code @ (@x@).

The thread ex4194 has exited with code @ (@x@).

The thread @xe54 has exited with code @ (@x@).

The thread 8x8f@ has exited with code @ (8x@8).

The program '[17288] Consolefpplication8.exe' has exited with code @ (@x@).

Package Manager Console Error List ollissin

7 Ready Ln 10 Col 30 h 27 S 4 Add to Source Control
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29] ConsoleApplicationd - Microsoft Visual Studio X & Quick Launch (Curl+Q) Pl - 0O

File Edit View Project Build Debug Team  Tools Test Analyze Window  Help Deborah Fowler -
- | B2 g | 9 - - | Debug = x86 = P Local Windows Debugger v| I = =) | = % | | =
E ConsoleApplication8.cpp & X * | Solution Explorer
I':J- %] ConsoleApplication® - (Global Scope) - @ mainf) - & & ,l o5 & r@| < ﬁE
; -1// ConsoleApplication&.cpp : This file contains the "main' function. Program execution bef Search Solution Explorer (Ctrl+:) p-
3 /1 fal Solution 'Consolefpplicationd' (1 project)
) N N 4 %] ConsoleApplication8
4 —i#include "pch.h [/ vs2017 b = References
5 #include <iostream> B 15 External Dependencies
6 using namespace std; b 27 Header Files
7 50 Resource Files
2 —int main() 4 .| Source Files
9 { I *+ Consclefpplication8.cpp
" 1 1 1 1 I *+ peh.cpp
10 TR \/isual Studios is a fully functional IDE with
11 T .
12 many features left to explore — keep in
13 -// Run program: Ctr"l
Tyl 1ind that the .sln file is coordinating all the
15
TR s \/ 2 iOUS files — if you were to use Geany or
17 Iy 1. Use the Soluti
PO A |USt gcc you would only need the source PR crcooc
19 // 3. Use the Output ( ) perties
20 J// 4. Use the Error Cpp and 'h fIIeS
21 // 5. Go to Project > Add New Item to create new code files, or Project > Add Existing
22 Iy 6. In the future, to open this project again, go to File > Open > Proiject and select ™
121% =~ 4 »
Output > o X
Show output from:  Debug - | | | & a
'ConsoleApplication8.exe’ (Win32): Loaded 'C:\Windows\SyskOW64\imm32.d11l'. Cannot find or open the PDE file. Y

The thread 8x3f@4 has exited with code @ (@x@).
The thread ex4194 has exited with code @ (@x@).
The thread @xe54 has exited with code @ (@x@).
The thread 8x8f@ has exited with code @ (8x@8).
The program '[17288] Consolefpplication8.exe' has exited with code @ (@x@).

Package Manager Console Error List ollissin

7 Ready Ln 10 Col 30 Ch 27 INS 4 Add to Source Control &
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